use strict;
my $str = 'Text of variable length spread across several lines Serialization-type text separated by colons (eg ABC:DEF:GHI) A date
From: One line of text To: One or more lines Subject: One or more lines References: One or more lines
From: One line of text To: One
or
more
lines Subject: One or more lines References: One or more lines
From: One line of text To: One or more lines Subject: No references.
From: One line of text To: One or more lines Subject: One
or
more
lines
References: One or more lines
Paragraph 1 Title: A paragraph
Paragraph 2 Title: Another paragraph';
my $regex = qr/From:\s+(?<from>.*?)\s+To:\s+(?<to>.*?)\s+Subject:\s+(?<subject>.*?)(?:\s+References: (?<ref>.*?))?$/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}