$re = '/From:\s+(?<from>.*?)\s+To:\s+(?<to>.*?)\s+Subject:\s+(?<subject>.*?)(?:\s+References: (?<ref>.*?))?$/ms';
$str = 'Text of variable length spread across several lines Serialization-type text separated by colons (eg ABC:DEF:GHI) A date
From: One line of text To: One or more lines Subject: One or more lines References: One or more lines
From: One line of text To: One
or
more
lines Subject: One or more lines References: One or more lines
From: One line of text To: One or more lines Subject: No references.
From: One line of text To: One or more lines Subject: One
or
more
lines
References: One or more lines
Paragraph 1 Title: A paragraph
Paragraph 2 Title: Another paragraph';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);