import re
regex = re.compile(r"From:\s+(?<from>.*?)\s+To:\s+(?<to>.*?)\s+Subject:\s+(?<subject>.*?)(?:\s+References: (?<ref>.*?))?$", flags=re.MULTILINE | re.DOTALL)
test_str = ("Text of variable length spread across several lines Serialization-type text separated by colons (eg ABC:DEF:GHI) A date\n\n"
"From: One line of text To: One or more lines Subject: One or more lines References: One or more lines\n\n"
"From: One line of text To: One \n"
"or \n"
"more \n"
"lines Subject: One or more lines References: One or more lines\n\n"
"From: One line of text To: One or more lines Subject: No references.\n\n"
"From: One line of text To: One or more lines Subject: One \n"
"or \n"
"more \n"
"lines \n"
"References: One or more lines\n\n"
"Paragraph 1 Title: A paragraph\n\n"
"Paragraph 2 Title: Another paragraph")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")