#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}(?=%)"
Local $sString = "Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libvlc$" & @CRLF & _
"" & @CRLF & _
"Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 fonts-freefont-ttf$" & @CRLF & _
"" & @CRLF & _
"40% [12 fonts-freefont-ttf 855 kB/4,140 kB 21%]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")