const regex = /^\d{1,3}(?=%)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,3}(?=%)', 'gm')
const str = `Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libvlc\$
Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 fonts-freefont-ttf\$
40% [12 fonts-freefont-ttf 855 kB/4,140 kB 21%]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}