import re
regex = re.compile(r"^\d{1,3}(?=%)", flags=re.MULTILINE)
test_str = ("Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libvlc$\n\n"
"Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 fonts-freefont-ttf$\n\n"
"40% [12 fonts-freefont-ttf 855 kB/4,140 kB 21%]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")