re = /^\d{1,3}(?=%)/m
str = 'Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libvlc$
Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 fonts-freefont-ttf$
40% [12 fonts-freefont-ttf 855 kB/4,140 kB 21%]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end