using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{3}[.-]?[0-9]{3,4})";
string input = @"This is my MAC 412.346.8021
Hey my number is +1(903)509-1123. Give me a call";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}