// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{3}[.-]?[0-9]{3,4})").unwrap();
let string = "This is my MAC 412.346.8021
Hey my number is +1(903)509-1123. Give me a call";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}