package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{3}[.-]?[0-9]{3,4})`)
var str = `This is my MAC 412.346.8021
Hey my number is +1(903)509-1123. Give me a call`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}