$re = '/([0-9]{3}[.-]?[0-9]{3,4})/m';
$str = 'This is my MAC 412.346.8021
Hey my number is +1(903)509-1123. Give me a call';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);