using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=\S*the\S*)[^t\s]*(?:t(?!heo)[^t\s]*)+\b";
string input = @"If the world says that theo is not oreo cookies then thetatheoder theotatheder thetatheder is extratheaterly good.
The then theotatheder thetatheo
It selects the text: theothatherd which should be skipped";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}