const regex = new RegExp('\\b(?=\\S*the\\S*)[^t\\s]*(?:t(?!heo)[^t\\s]*)+\\b', 'gmi')
const str = `If the world says that theo is not oreo cookies then thetatheoder theotatheder thetatheder is extratheaterly good.
The then theotatheder thetatheo
It selects the text: theothatherd which should be skipped`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}