import re
regex = re.compile(r"\b(?=\S*the\S*)[^t\s]*(?:t(?!heo)[^t\s]*)+\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("If the world says that theo is not oreo cookies then thetatheoder theotatheder thetatheder is extratheaterly good.\n"
"The then theotatheder thetatheo\n"
"It selects the text: theothatherd which should be skipped")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")