import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=\\S*the\\S*)[^t\\s]*(?:t(?!heo)[^t\\s]*)+\\b";
final String string = "If the world says that theo is not oreo cookies then thetatheoder theotatheder thetatheder is extratheaterly good.\n"
+ "The then theotatheder thetatheo\n"
+ "It selects the text: theothatherd which should be skipped";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}