using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=\""(.*?)\""";
string input = @"[<a class=""lightbox"" href=""fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie.jpg"" title=""><img alt=""Sprachschule EC San Diego"" border=""0"" height=""80"" src=""typo3temp/pics/EC_San_Diego_Galerie_d1def1bf4a.jpg"" title=""Sprachschule EC San Diego (Copyright EC San Diego. All rights reserved.)"" width=""80""/></a>, <a class=""lightbox"" href=""fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_1_.jpg"" title=""><img alt=""Sprachschule EC San Diego 2"" border=""0"" height=""80"" src=""typo3temp/pics/EC_San_Diego_Galerie-_1__fd87630014.jpg"" title=""Sprachschule EC San Diego 2 (Copyright EC San Diego. All rights reserved.)"" width=""80""/></a>, <a class=""lightbox"" href=""fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_10_.jpg"" title=""><img alt=""Sprachschule EC San Diego 3"" border=""0"" height=""80"" src=""typo3temp/pics/EC_San_Diego_Galerie-_10__a8ed60c277.jpg"" title=""Sprachschule EC San Diego 3 (Copyright EC San Diego. All rights reserved.)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}