// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href=\"(.*?)\""#).unwrap();
let string = "[<a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie_d1def1bf4a.jpg\" title=\"Sprachschule EC San Diego (Copyright EC San Diego. All rights reserved.)\" width=\"80\"/></a>, <a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_1_.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego 2\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie-_1__fd87630014.jpg\" title=\"Sprachschule EC San Diego 2 (Copyright EC San Diego. All rights reserved.)\" width=\"80\"/></a>, <a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_10_.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego 3\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie-_10__a8ed60c277.jpg\" title=\"Sprachschule EC San Diego 3 (Copyright EC San Diego. All rights reserved.)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}