import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\\\"(.*?)\\\"";
final String string = "[<a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie_d1def1bf4a.jpg\" title=\"Sprachschule EC San Diego (Copyright EC San Diego. All rights reserved.)\" width=\"80\"/></a>, <a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_1_.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego 2\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie-_1__fd87630014.jpg\" title=\"Sprachschule EC San Diego 2 (Copyright EC San Diego. All rights reserved.)\" width=\"80\"/></a>, <a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_10_.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego 3\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie-_10__a8ed60c277.jpg\" title=\"Sprachschule EC San Diego 3 (Copyright EC San Diego. All rights reserved.)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}