# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=\"(.*?)\""
test_str = "[<a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie_d1def1bf4a.jpg\" title=\"Sprachschule EC San Diego (Copyright EC San Diego. All rights reserved.)\" width=\"80\"/></a>, <a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_1_.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego 2\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie-_1__fd87630014.jpg\" title=\"Sprachschule EC San Diego 2 (Copyright EC San Diego. All rights reserved.)\" width=\"80\"/></a>, <a class=\"lightbox\" href=\"fileadmin/user_upload/images/Sprachen/Englisch/USA/San_Diego/San_Diego_EC/EC_San_Diego_Galerie-_10_.jpg\" title=\"\"><img alt=\"Sprachschule EC San Diego 3\" border=\"0\" height=\"80\" src=\"typo3temp/pics/EC_San_Diego_Galerie-_10__a8ed60c277.jpg\" title=\"Sprachschule EC San Diego 3 (Copyright EC San Diego. All rights reserved.)"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.