#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/.*?[\s+]"
Local $sString = "http://www.youtube.com/watch?v=qsXHcwe3krw" & @CRLF & _
"http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg" & @CRLF & _
"enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks" & @CRLF & _
"https://www.youtube.com/watch?v=iz7lE1g4XM4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")