import re
regex = re.compile(r"https?:\/\/.*?[\s+]", flags=re.MULTILINE)
test_str = ("http://www.youtube.com/watch?v=qsXHcwe3krw\n"
"http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg\n"
"enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks\n"
"https://www.youtube.com/watch?v=iz7lE1g4XM4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")