re = /https?:\/\/.*?[\s+]/m
str = 'http://www.youtube.com/watch?v=qsXHcwe3krw
http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg
enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks
https://www.youtube.com/watch?v=iz7lE1g4XM4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end