import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/.*?[\\s+]";
final String string = "http://www.youtube.com/watch?v=qsXHcwe3krw\n"
+ "http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg\n"
+ "enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks\n"
+ "https://www.youtube.com/watch?v=iz7lE1g4XM4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}