re = /(.),(.)/m
str = 'SELECT
di.QuestionSetID AS SectionID,
,di.ScoreNBR AS Section,LowestTopBoxNBR
,di.AveragePercentileNBR AS SectionTopBoxPercentileRankNBR
,qdate.Quarter,StartDTS AS Section,StartDTS
FROM NRCPicker.PatientSatisfaction.DimensionPercentile AS di
INNER JOIN (
asdf,,asdf,
,ll
,,,,,,
,,'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result