import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!Cost\\s+price\\s+of\\s+boat\\s+:)(?<=^|\\v).*";
final String string = "One time fee : 5000\n"
+ "Cost price of boat :$29242 NLC by Micheal\n"
+ "Total paid for boat (inc. recond) : \n"
+ "Payment due : \n"
+ "Expected receipt $ :";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}