re = /(?!Cost\s+price\s+of\s+boat\s+:)(?<=^|\v).*/
str = 'One time fee : 5000
Cost price of boat :$29242 NLC by Micheal
Total paid for boat (inc. recond) :
Payment due :
Expected receipt $ :'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end