$re = '/(?!Cost\s+price\s+of\s+boat\s+:)(?<=^|\v).*/';
$str = 'One time fee : 5000
Cost price of boat :$29242 NLC by Micheal
Total paid for boat (inc. recond) :
Payment due :
Expected receipt $ :';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);