const regex = /(?!Cost\s+price\s+of\s+boat\s+:)(?<=^|\v).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!Cost\\s+price\\s+of\\s+boat\\s+:)(?<=^|\\v).*', 'g')
const str = `One time fee : 5000
Cost price of boat :\$29242 NLC by Micheal
Total paid for boat (inc. recond) :
Payment due :
Expected receipt \$ :`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}