#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+)\h+-\h+\1$"
Local $sString = "9993990487 - 9993990487" & @CRLF & _
"9993990553 - 9993990553" & @CRLF & _
"9993990554 - 9993990559" & @CRLF & _
"9993990570 - 9993990570" & @CRLF & _
"9993990593 - 9993990596" & @CRLF & _
"9993990594 - 9993990594"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)