import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)\\h+-\\h+\\1$";
final String string = "9993990487 - 9993990487\n"
+ "9993990553 - 9993990553\n"
+ "9993990554 - 9993990559\n"
+ "9993990570 - 9993990570\n"
+ "9993990593 - 9993990596\n"
+ "9993990594 - 9993990594";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}