const regex = /^(\d+)\h+-\h+\1$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\h+-\\h+\\1$', 'gm')
const str = `9993990487 - 9993990487
9993990553 - 9993990553
9993990554 - 9993990559
9993990570 - 9993990570
9993990593 - 9993990596
9993990594 - 9993990594`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);