#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w]+=[\w" :]+"
Local $sString = "<table id="this is id">" & @CRLF & _
"<tr id="this tr id">" & @CRLF & _
"<a href="https://www.w3schools.com">Visit W3Schools.com!</a>" & @CRLF & _
"<div id="this is div id"><span id="div Class:a">this is span text</span></div>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")