import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w]+=[\\w\" :]+";
final String string = "<table id=\"this is id\">\n"
+ "<tr id=\"this tr id\">\n"
+ "<a href=\"https://www.w3schools.com\">Visit W3Schools.com!</a>\n"
+ "<div id=\"this is div id\"><span id=\"div Class:a\">this is span text</span></div>\n"
+ "</tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}