// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\w]+=[\w" :]+"#).unwrap();
let string = "<table id=\"this is id\">
<tr id=\"this tr id\">
<a href=\"https://www.w3schools.com\">Visit W3Schools.com!</a>
<div id=\"this is div id\"><span id=\"div Class:a\">this is span text</span></div>
</tr>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}