using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]+=[\w"" :]+";
string input = @"<table id=""this is id"">
<tr id=""this tr id"">
<a href=""https://www.w3schools.com"">Visit W3Schools.com!</a>
<div id=""this is div id""><span id=""div Class:a"">this is span text</span></div>
</tr>
</table>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}