const regex = /^(https:\/\/)*(localhost|airhelp.com)\/(?!en|nl|pt).*\/.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https:\\\/\\\/)*(localhost|airhelp.com)\\\/(?!en|nl|pt).*\\\/.*$', 'gm')
const str = `/en/airlines/
localhost/en-gb/airlines/
localhost/en-gb/
localhost/pl/
localhost/nl/
localhost/pt/
localhost/pt-br/
airhelp.com/pl/
airhelp.com/en/
airhelp.com/en-gb/
airhelp.com/pt/
airhelp.com/pl/airlines/dupa
https://localhost/en/
https://localhost/en-gb/
https://localhost/pl/
https://localhost/nl/
https://localhost/pt/
https://localhost/pt-br/
https://airhelp.com/pl/
https://airhelp.com/en/
https://airhelp.com/en-gb/
https://airhelp.com/pt/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}