import re
regex = re.compile(r"^(https:\/\/)*(localhost|airhelp.com)\/(?!en|nl|pt).*\/.*$", flags=re.MULTILINE)
test_str = ("/en/airlines/\n"
"localhost/en-gb/airlines/\n"
"localhost/en-gb/\n"
"localhost/pl/\n"
"localhost/nl/\n"
"localhost/pt/\n"
"localhost/pt-br/\n"
"airhelp.com/pl/\n"
"airhelp.com/en/\n"
"airhelp.com/en-gb/\n"
"airhelp.com/pt/\n"
"airhelp.com/pl/airlines/dupa\n\n"
"https://localhost/en/\n"
"https://localhost/en-gb/\n"
"https://localhost/pl/\n"
"https://localhost/nl/\n"
"https://localhost/pt/\n"
"https://localhost/pt-br/\n"
"https://airhelp.com/pl/\n"
"https://airhelp.com/en/\n"
"https://airhelp.com/en-gb/\n"
"https://airhelp.com/pt/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")