re = /^(https:\/\/)*(localhost|airhelp.com)\/(?!en|nl|pt).*\/.*$/m
str = '/en/airlines/
localhost/en-gb/airlines/
localhost/en-gb/
localhost/pl/
localhost/nl/
localhost/pt/
localhost/pt-br/
airhelp.com/pl/
airhelp.com/en/
airhelp.com/en-gb/
airhelp.com/pt/
airhelp.com/pl/airlines/dupa
https://localhost/en/
https://localhost/en-gb/
https://localhost/pl/
https://localhost/nl/
https://localhost/pt/
https://localhost/pt-br/
https://airhelp.com/pl/
https://airhelp.com/en/
https://airhelp.com/en-gb/
https://airhelp.com/pt/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end