#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=[\w-!.+,:;]*[A-Z][\w-!.+,:;]*)(?=[\w-!.+,:;]*[0-9][\w-!.+,:;]*)(?=[\w-!.+,:;]*[a-z][\w-!.+,:;]*)[\w-!.+,:;]{10,}$"
Local $sString = "Test1234jgsX.,asdhu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")