using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[\w-!.+,:;]*[A-Z][\w-!.+,:;]*)(?=[\w-!.+,:;]*[0-9][\w-!.+,:;]*)(?=[\w-!.+,:;]*[a-z][\w-!.+,:;]*)[\w-!.+,:;]{10,}$";
string input = @"Test1234jgsX.,asdhu";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}