re = /^(?=[\w-!.+,:;]*[A-Z][\w-!.+,:;]*)(?=[\w-!.+,:;]*[0-9][\w-!.+,:;]*)(?=[\w-!.+,:;]*[a-z][\w-!.+,:;]*)[\w-!.+,:;]{10,}$/
str = 'Test1234jgsX.,asdhu'
# Print the match result
str.match(re) do |match|
puts match.to_s
end