$re = '/^(?=[\w-!.+,:;]*[A-Z][\w-!.+,:;]*)(?=[\w-!.+,:;]*[0-9][\w-!.+,:;]*)(?=[\w-!.+,:;]*[a-z][\w-!.+,:;]*)[\w-!.+,:;]{10,}$/';
$str = 'Test1234jgsX.,asdhu';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);