using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[:.](.+?руб)";
string input = @"Ингредиенты: Дор блю 50 г + 100 руб.Бекон 50 г + 100 руб.Халапеньо 20 г + 50 руб.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}