$re = '/[:.](.+?руб)/';
$str = 'Ингредиенты: Дор блю 50 г + 100 руб.Бекон 50 г + 100 руб.Халапеньо 20 г + 50 руб.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);