// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[:.](.+?руб)").unwrap();
let string = "Ингредиенты: Дор блю 50 г + 100 руб.Бекон 50 г + 100 руб.Халапеньо 20 г + 50 руб.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}