package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[:.](.+?руб)`)
var str = `Ингредиенты: Дор блю 50 г + 100 руб.Бекон 50 г + 100 руб.Халапеньо 20 г + 50 руб.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}