import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[[^\\w\\-]]+)(task|tasks)[^a-z\\-]*(?<TO>[\\d]{1,2})_(subtask|subtasks)[^a-z\\-]*(?<TT>[\\d]{1,2})";
final String string = "task1_subtask13\n"
+ "task56_subtask78";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}