re = /(^|[[^\w\-]]+)(task|tasks)[^a-z\-]*(?<TO>[\d]{1,2})_(subtask|subtasks)[^a-z\-]*(?<TT>[\d]{1,2})/m
str = 'task1_subtask13
task56_subtask78'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end