$re = '/(^|[[^\w\-]]+)(task|tasks)[^a-z\-]*(?<TO>[\d]{1,2})_(subtask|subtasks)[^a-z\-]*(?<TT>[\d]{1,2})/m';
$str = 'task1_subtask13
task56_subtask78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);