import re
regex = re.compile(r"(^|[[^\w\-]]+)(task|tasks)[^a-z\-]*(?<TO>[\d]{1,2})_(subtask|subtasks)[^a-z\-]*(?<TT>[\d]{1,2})", flags=re.MULTILINE)
test_str = ("task1_subtask13\n"
"task56_subtask78")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")